Google+

Função SE – Aprenda como usar

Junto com o PROCV, a função SE é uma das mais utilizadas no Excel. Sua versatilidade permite que trabalhemos tanto com valores numéricos, como com textos. O principal uso da função SE é nos ajudar a automatizar decisões dentro de uma planilha, no que chamamos de estrutura condicional. Basicamente é uma estrutura do tipo:

  • SE alguma coisa Acontecer ENTÃO faça alguma coisa.

A sintaxe da função SE é dada por:

=SE(TESTE LÓGICO; VALOR SE VERDADEIRO; VALOR SE FALSO)

Como primeiro exemplo, fazer o teste mais simples: verificar se 2 é maior que 1. No Excel, fazemos:

=SE(2>1; “Verdade”; “Falso”)

1 - função se

Vamos pensar agora em uma estrutura de uma pesquisa de opinião com cliente. Suponha que temos a seguinte planilha que foi preenchida em nossa pesquisa:

2 - função se tabela

Nosso cliente dará uma nota ao produto e uma nota ao vendedor. O uso da função SE será fundamental agora. Com ela, poderemos avaliar automaticamente o resultado da pesquisa (imagine que a pesquisa será bem extensa, com mais de 1000 respondentes), sem nos preocupar em olhar cada registro individualmente. Segundo nosso Diretor Vendas, temos a seguinte condição de avaliação:

  • Se a nota do produto for maior que ou igual a 7 e a nota do vendedor maior que ou igual a 6, consideramos o cliente satisfeito; Do contrário, consideramos o cliente insatisfeito.

Assim, vamos começar nossa avaliação, segundo a condição dado pelo nosso Diretor. No Excel, vamos inserir

=SE(E(C5>=7;D5>=6);”Satisfeito”;”Insatisfeito”) onde temos, segundo a estrutura que explicamos no começo do artigo

  • E(C5>=7;D5>=6) é o nosso TESTE LÓGICO -> estamos utilizando a função E() do Excel (Clique aqui para saber mais sobre funções e operadores lógicos) onde ela retorna verdadeiro se, ao mesmo tempo, a nota do produto for maior ou igual a 7 (C5>=7) E a nota do vendedor for maior ou igual a 6 (D5>=6); Justamente a condição dada pelo nosso Diretor. Por isso ela é colocada em nosso TESTE LÓGICO da função SE;
  • “Satisfeito” é o nosso VALOR SE VERDADEIRO -> é o resultado que queremos retornar caso nosso TESTE LÓGICO seja verdade;
  • “Insatisfeito” é o nosso VALOR SE FALSO -> é o resultado que queremos retornar caso nosso TESTE LÓGICO seja falso;

Assim, nossa primeira avaliação retorna que o cliente está insatisfeito.

3 - função se fórmula

Seguindo com a avaliação, repetimos a função SE para as demais linhas e ficamos com nossa planilha como mostra a próxima figura

4

Ou seja, nossos clientes estão, na maioria, insatisfeitos. Porém, ainda falta avaliarmos resultado final da pesquisa no Excel, e não apenas olhando os resultados. Consideramos que, se a maioria das notas mostrar um cliente satisfeito, vamos ter uma avaliação final POSITIVA; do contrário, NEGATIVA. Assim, sabemos que o total de respondentes foi 4. Logo, se a quantidade de clientes satisfeitos for maior que 2, teremos uma avaliação POSITIVA. Assim, vamos fazer uma coluna auxiliar onde teremos o valor 1 se a Nota Satisfação foi Satisfeito, e 0 caso contrário. Ou seja, nossa função SE fica

=SE(F5=”Satisfeito”;1;0)

como vemos na próxima figura.

5

 Fazendo para as demais temos:

6 - função se resultado

O total é dado pela soma simples. Assim, criando nossa última função, vamos criar o resultado final, que será mostrado ao Diretor de Vendas. Fazemos:

=SE(H9>2;”POSITIVA”;”NEGATIVA”)

onde H9 é o resultado de nossa soma auxiliar.

7

Ou seja, a empresa tem que trabalhar mais seus produtos e vendedores para satisfazer o cliente.

Mostramos como a função SE é importante para automatizar decisões e situações de condições em planilhas, podendo ser usada diversas vezes em uma mesma planilha e também ao mesmo tempo com outras funções onde podemos atribuir à diversas condições.

email
Updated: 29/09/2014 — 16:46

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Excel Prático © Todos os direitos reservados. 2014 - 2016